United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Massachusetts
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jun 07, 2024 - 20:53 UTC
Update
A majority of public access terminals are back up and running across the state. Please continue to expect delays as we work through the backlog.
Posted Jun 05, 2024 - 21:01 UTC
Monitoring
The public access terminals across the state of Massachusetts are experiencing technical issues. Our researchers have notified the court, but there's no ETA on when the issue will be resolved. Please expect delays for the time being.
Posted Jun 04, 2024 - 20:19 UTC