Data Status Page

This page contains information about third-party data source disruptions and delays.

Georgia Superior Court (Multi-County) – Court Processing Delays

Incident Report for Checkr Data Status

Update

Automated search processing across these Georgia counties has resumed. Some searches may continue to experience delays as the backlog clears. No ETA for resolution at this time.
Posted Aug 05, 2026 - 00:10 UTC

Update

Maintenance in the following Georgia counties: Cherokee, Clarke, Dawson, Fayette, Hall, Jackson, Paulding, Richmond, Troup, Upson, and Walker: is now back online. Some Searches may experience delays.
Posted Jul 01, 2026 - 22:15 UTC

Monitoring

The Georgia Superior Court automation is offline due to maintenance, impacting the following counties: Cherokee, Clarke, Dawson, Fayette, Hall, Jackson, Paulding, Richmond, Troup, Upson, and Walker. Searches may experience delay until restored. There is no ETA at this time.
Posted Jun 24, 2026 - 20:58 UTC