United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Virginia DMV is Offline

Incident Report for Checkr US Data Status

Resolved

Virginia DMV is back online and MVRs are once again processing as normal.
Posted Apr 21, 2025 - 18:51 UTC

Update

Virginia DMV is back online but there may be increased TAT for some Virginia driving records as we continue to work with the state.
Posted Apr 21, 2025 - 18:10 UTC

Investigating

The Virginia DMV is currently offline and MVRs will be unavailable through the weekend. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Apr 19, 2025 - 00:20 UTC