United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Maintenance] Washington AOC

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 22:10 UTC

Monitoring

WA AOC has scheduled maintenance for Saturday Feb. 8th though Sunday Feb. 9th. Service interruptions are expected during this time.
Posted Feb 05, 2025 - 16:17 UTC

Investigating

WA AOC has scheduled maintenance for Saturday Feb. 8th though Sunday Feb. 9th. Service interruptions are expected during this time.
Posted Feb 05, 2025 - 16:15 UTC