Data Status Page

This page contains information about third-party data source disruptions and delays.

Abuse Registry and FACIS Searches – Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved - normal search operations have resumed
Posted Sep 16, 2026 - 19:36 UTC

Update

Errors from the third-party provider have stopped and processing is being monitored for stability. Previously submitted searches may continue to experience some delay as the backlog clears.
Posted Sep 16, 2026 - 19:06 UTC

Monitoring

We are monitoring a technical issue with one of our third-party data providers affecting Abuse Registry and FACIS searches. Some searches may experience longer than normal turnaround times. No ETA for resolution at this time.
Posted Sep 16, 2026 - 16:33 UTC