United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] St. Claire, IL Court System Down
Incident Report for Checkr US Data Status
Resolved
06/09/2021: The St. Claire, IL system is back up and running and orders are now able to be processed.
Posted Jun 09, 2021 - 22:04 UTC
Monitoring
06/07/2021: St. Claire, IL is still down and currently there is still no ETA for when this will be back up. We will continue to monitor this.
Posted Jun 07, 2021 - 22:39 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2021 - 21:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2021 - 21:12 UTC
Identified
06/03/2021: The online record system in St. Claire, IL went down unexpectedly due to a ransomware attack and they are unable to complete any searches. There is currently a tentative ETA of June 7th for this to be back up, but we will continue to monitor this.

*This will affect the completion for all searches*
Posted Jun 03, 2021 - 20:40 UTC