United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Severe Weather Advisory — Southern Plains, Midwest, Northeast

Incident Report for Checkr US Data Status

Update

Many courts have reopened following Winter Storm Fern. Closures remain in KY, MD, MO, TN, VA, and WV. An additional winter storm is expected to impact the East Coast this weekend. Courts may announce schedule changes or closures depending on conditions. Please continue to expect delays in affected jurisdictions.
Posted Jan 29, 2026 - 20:04 UTC

Monitoring

Many courts have reopened following Winter Storm Fern. Closures remain in KY, MD, MO, TN, VA, and WV. An additional winter storm is expected to impact the East Coast this weekend. Courts may announce schedule changes or closures depending on conditions. Please continue to expect delays in affected jurisdictions.
Posted Jan 29, 2026 - 14:00 UTC