United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 16:24 UTC
Identified
The following DMVs will be performing scheduled maintenance during these times on Sunday, 4/7:

New Jersey: 4:30-8am PT
Kentucky: 5-7am PT
Arkansas: 6-11am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Apr 05, 2024 - 18:31 UTC