Data Status Page

This page contains information about third-party data source disruptions and delays.

Weekend DMV Scheduled Maintenance

Incident Report for Checkr Data Status

Resolved

This incident has been resolved.
Posted Jan 31, 2024 - 18:11 UTC

Identified

The following DMVs will be performing scheduled maintenance over the coming days during the times listed below (all times Pacific):

Tennessee: Friday, January 26 at 8pm until Saturday, January 27 at 2am
Delaware: Saturday, January 27 at 1am until Sunday, January 28 at 1am
Hawaii: Saturday, January 27 from 8am until 4pm
Georgia: Sunday, January 28 from 3:30pm until 10:30pm
Texas: Sunday, January 28 from 4pm until 11pm

MVRs requested in these states during the listed times will not be completed until the scheduled maintenance is completed.
Posted Jan 25, 2024 - 18:37 UTC