[Outage] Arizona DMV is Offline
Incident Report for Checkr Data Status
Resolved
11/12/2021: The Arizona DMV is back online and orders are now able to be processed.
Posted Nov 13, 2021 - 00:00 UTC
Investigating
11/11/2021: The Arizona online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update as we learn more.
Posted Nov 11, 2021 - 21:13 UTC