United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

8/28/2023: General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 22:49 UTC
Monitoring
**Please note courthouses will be closed on Monday, September 4, 2023 in observance of Labor Day.**

High Impact

--CA: Sacramento - Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.
--GA: Fulton - Site instability has caused slowdowns with processing. Please expect delays.

Medium Impact

--CA: San Joaquin - Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.
--GA: Richmond - The court is still recovering from a recent cyber attack and all information still needs to be verified with clerks. Please expect delays.
--NH: All counties - Courthouses are experiencing staffing issues. Please expect delays.
Posted Aug 28, 2023 - 23:38 UTC