United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Massachusetts Cyber Attack
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Dec 12, 2023 - 17:43 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 11, 2023 - 23:55 UTC
Update
The system has been brought back online and courts are now available for research in a majority of jurisdictions in Massachusetts. Please expect delays as the courts work through backlogs.
Posted Nov 28, 2023 - 21:18 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2023 - 00:33 UTC
Update
The system has been brought back online and courts are now available for research in a majority of jurisdictions in Massachusetts. Please expect delays as the courts work through backlogs.
Posted Nov 09, 2023 - 18:05 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 08, 2023 - 17:59 UTC
Monitoring
The system that supports critical functions within the courthouses was subject to a cyber-attack. We are expecting delays to last for at least several days before restoration. This outage affects all counties.
Posted Nov 03, 2023 - 17:24 UTC