Automated search processing has been restored. Some searches may continue to experience delays as the queue clears.
Posted May 29, 2026 - 13:02 UTC
Update
Automated search processing has been restored. Some searches requiring clerk assistance and may take longer than usual to complete. The queue is expected to clear by June 5.
Posted May 26, 2026 - 15:50 UTC
Update
Statewide system instability is impacting automated search processing. Searches are being fulfilled through a combination of automated and manual processing methods, and some searches may experience longer than normal turnaround times. No ETA for resolution at this time.
Posted May 21, 2026 - 16:54 UTC
Monitoring
A recent site change has impacted automated search processing, taking automation offline. Searches are being fulfilled manually. Please expect longer than normal turnaround times until automation is restored.