United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Maryland Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 06, 2024 - 14:09 UTC
Identified
Maryland Electronic Courts (MDEC), Case Search will be unavailable beginning Friday, May 3 @ 6pm until Monday, May 6 @ 8am. Requests received during this time will not be completed until the scheduled maintenance is done. Please expect delays.
Posted May 03, 2024 - 19:48 UTC