United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Monitoring Potential Election Day Court Closures
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 13:07 UTC
Monitoring
As Election Day approaches on November 5th, we want to assure you that Checkr is actively monitoring all court operations. At this time, we have not been notified of any scheduled closures due to the election. However, should any disruptions occur, we are committed to keeping you informed promptly.

Thank you for your trust in Checkr. Please feel free to reach out to us with any questions or concerns.
Posted Nov 04, 2024 - 18:25 UTC