United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Veterans Day - Wednesday, Nov. 11
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 17:48 UTC
Identified
Many courts across the country will be closed on Wednesday, November 11 in observance of Veterans Day. Some reports will be delayed due to lack of access to courthouses.
Posted Nov 09, 2020 - 18:16 UTC