United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Statewide FL (FDLE)

Incident Report for Checkr US Data Status

Update

Florida Statewide (FDLE) searches are now processing slowly. Please expect delays. We are continuing to monitor the situation. This is only impacting statewide orders — all county-level criminal searches are processing normally.
Posted Jun 05, 2025 - 15:50 UTC

Monitoring

Florida Statewide (FDLE) searches are not processing due to automation issues. We are monitoring the situation. This is only impacting statewide orders — all county-level criminal searches are processing normally.
Posted May 29, 2025 - 20:54 UTC