United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

11/6/2023: General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 00:23 UTC
Monitoring
**Please note many courthouses will be closed on Friday, November 10, 2023 in observance of Veterans Day.**

High Impact

--CA: Sacramento - Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.
--CA: San Bernardino - The date of birth has been removed from in-court public access terminals. Searches with possible records will be reliant on clerk assistance to be completed. Expect delays.
--VA: Fairfax - Changes in the online index has created a slowdown in processing. Please expect extended delays.

Medium Impact

--CA: San Joaquin - Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.
--IL: Lake - Site instability has caused slowdown in processing. Please expect delays.
--NH: All counties - Courthouses are experiencing staffing issues. Please expect delays.
--TX: Harris - Searches are being manually processed, expect delays.

Low Impact

--GA: Fulton - Site instability has caused slowdowns with processing. Please expect delays
--TX: Hale - Ongoing issues accessing case dockets via the court primary index. Searches with possible records can not be processed at this time. Please expect delays.
--TX: Upshur - Changes in the online index has created a slowdown in processing. Please expect delays.
Posted Nov 07, 2023 - 00:39 UTC