United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 22, 2023 - 16:23 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Saturday, 5/20
Maine: 7-11am PT

Sunday, 5/21
Kentucky: 12-7am PT
Illinois: 2-6am PT
Rhode Island: 4-7am PT
Minnesota: 4-11am PT
Washington: 8am-1pm PT
Hawaii: 9am-12pm PT
South Carolina: 3-7pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted May 19, 2023 - 16:44 UTC