United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 16:55 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend (all times in Pacific Time):

Saturday, 9/17
Idaho: 5am-1pm
Georgia: 10am-8pm

Sunday, 9/18
Kentucky: 12-7am
Pennsylvania: 12-6am
Texas: 4-8am
Arkansas: 6-10am
Oklahoma: 10am-5pm
South Carolina: 3-7pm

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Sep 16, 2022 - 21:31 UTC