Some searches in Vermilion, DeKalb, Champaign, LaSalle, Madison, and Cook counties are experiencing longer-than-usual processing times due to elevated review and clerk-assisted workflow volume. Additional staffing has been added and process improvements are being implemented. Older orders are being prioritized. No ETA for full resolution at this time.
Posted Sep 09, 2026 - 01:02 UTC
Update
Some searches in Illinois are experiencing longer than normal turnaround times as staffing capacity is added to address a processing backlog. Impacted counties include: Champaign, DeKalb, LaSalle, Madison, and Vermillion. No ETA for resolution at this time.
Posted Sep 05, 2026 - 00:08 UTC
Update
Some searches in Illinois are experiencing longer than normal turnaround times as staffing capacity is added to address a processing backlog. No ETA for resolution at this time.
Posted Aug 31, 2026 - 22:42 UTC
Update
Some searches in Illinois are experiencing longer than normal turnaround times. Oldest orders are being prioritized. No ETA for resolution at this time.
Posted Aug 12, 2026 - 17:41 UTC
Monitoring
Due to automation instability, some searches may experience delays. No ETA at this time.