United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Nebraska DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 00:32 UTC
Identified
The Nebraska DMV will be performing scheduled maintenance today from 4-5pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Mar 16, 2023 - 18:03 UTC