United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Arizona Counties

Incident Report for Checkr US Data Status

Update

The Arizona Judicial Branch portal updated its website, resulting in connectivity issues. As a result, searches in the following counties Apache, Cochise, Coconino, Mohave, Navajo, Pinal, and Santa Cruz are only being processed manually. Please continue to expect delays. We are monitoring the situation.
Posted Feb 21, 2025 - 18:29 UTC

Update

The Arizona Judicial Branch portal has recently updated its website, resulting in connectivity issues. As a result, searches in the following counties Apache, Cochise, Coconino, Mohave, Navajo, Pinal, and Santa Cruz are only being processed manually. Please continue to expect delays.
We are monitoring the situation.
Posted Feb 06, 2025 - 17:37 UTC

Update

The Arizona Judicial Branch portal has recently updated its website, resulting in connectivity issues. As a result, searches are only being processed manually please expect delays in the following AZ counties: Apache, Cochise, Coconino, Mohave, Navajo, Pinal, and Santa Cruz.
We are monitoring the situation.
Posted Jan 31, 2025 - 20:29 UTC

Update

The Arizona Judicial Branch portal has recently updated its website, resulting in connectivity issues. As a result, searches are only being processed manually please expect delays in the following AZ counties: Apache, Cochise, Coconino, Mohave, Navajo, Pinal, and Santa Cruz.
Posted Jan 30, 2025 - 22:25 UTC

Update

The Arizona Judicial Branch portal has recently updated its website, resulting in connectivity issues. As a result, searches are being processed manually, leading to anticipated delays in the following counties: Apache, Cochise, Coconino, Mohave, Navajo, Pinal, and Santa Cruz.
Posted Jan 24, 2025 - 21:19 UTC

Monitoring

The Arizona Judicial Branch portal updated its website, causing connectivity issues with automation and are not processing at this time. Please anticipate delays in the following counties:
Apache, Cochise, Coconino, Mohave, Navajo, Pinal, and Santa Cruz.
Posted Jan 24, 2025 - 22:26 UTC