United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Letcher, KY
Incident Report for Checkr US Data Status
Resolved
The Letcher KY courts have reopened. Please anticipate some delays in this jurisdiction as our researchers work through searches.
Posted Sep 30, 2024 - 17:51 UTC
Monitoring
Due to an incident that occurred within the Letcher County KY Court on Sept. 19, 2024, the court will remain closed until Monday, September 30th. We are unable to process searches at this time. Please expect delays.
Posted Sep 24, 2024 - 20:18 UTC