United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Maintenance] Maryland

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 13:11 UTC

Monitoring

The Maryland Judiciary will launch a new Case Search portal on January 9, 2026, after 6 p.m. Service interruptions may occur during and after the transition to the new portal.
Posted Jan 09, 2026 - 20:08 UTC