Data Status Page

This page contains information about third-party data source disruptions and delays.

Kent County, MI - Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved – Normal search processing has resumed
Posted May 18, 2026 - 16:03 UTC

Update

Automated search processing has been restored in Kent County. Some searches may continue to experience delays as the remaining backlog clears.
Posted May 15, 2026 - 21:06 UTC

Monitoring

The 61st District Court system is currently experiencing issues impacting processing, and all searches are currently blocked. The court is aware of the issue and is working toward a resolution, but there is no ETA at this time.
Posted May 13, 2026 - 20:58 UTC