United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] SMITH, TX
Incident Report for Checkr US Data Status
Resolved
The public access terminal is back online, and we are now processing searches. Please continue to anticipate delays as our researchers work through the backlog.
Posted Oct 30, 2024 - 15:55 UTC
Monitoring
The public access terminal is currently down with no ETA for restoration. As a result, we are unable to process searches. We will continue to monitor the situation and notify you of any updates.
Posted Oct 15, 2024 - 17:49 UTC