Data Status Page

This page contains information about third-party data source disruptions and delays.

North Dakota Statewide – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved- normal operations have resumed.
Posted Aug 29, 2026 - 01:02 UTC

Update

Search processing has resumed. Some searches may experience delays as the queue clears. There is no ETA for resolution at this time.
Posted Aug 10, 2026 - 18:57 UTC

Monitoring

System instability. Searches are being processed manually and may experience delays. No ETA for resolution at this time.
Posted Aug 07, 2026 - 15:26 UTC