United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Brooks, GA
Incident Report for Checkr US Data Status
Resolved
The court in Brooks GA is back to normal operations. Please expect delays as the researchers catch up on searches.
Posted Sep 18, 2024 - 20:42 UTC
Monitoring
The server is down in the Brooks, GA courthouse and is offline today. No searches will be processed until they are able to get online. There is no ETA for when the court will reopen. We will continue to monitor the situation and will notify you of any changes.
Posted Sep 03, 2024 - 19:17 UTC