United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Hillsborough, FL

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted May 23, 2025 - 18:07 UTC

Update

Searches are now processing for Hillsborough, FL however we are experiencing delays as we work through the backlog . We are monitoring the situation.
Posted May 21, 2025 - 13:29 UTC

Monitoring

Due to website instability, searches are not processing for Hillsborough, FL. We are looking into other processing solutions at this time and closely monitoring the situation.
Posted May 15, 2025 - 21:01 UTC

Identified

Due to website instability, searches are not processing for Hillsborough, FL. We are looking into other processing solutions at this time and closely monitoring the situation.
Posted May 13, 2025 - 15:02 UTC