The PR Police system is back online but processing slowly. Clears and records not requiring additional review are being returned, at a slower rate. Searches requiring review by the Analysis Department remain on hold until that team is fully operational. Please continue to expect delays. We are monitoring the situation.
Posted Jun 26, 2025 - 19:47 UTC
Update
The Puerto Rico Police system outage is still ongoing. However, we are now able to process clears. Searches with potential records will remain on hold until access to the Police system is restored. We are actively monitoring the situation and will provide updates as soon as more information becomes available.
Posted Jun 24, 2025 - 19:32 UTC
Monitoring
The Puerto Rican Police are currently experiencing a system outage with no ETA for restoration. Searches are not processing at this time. We are monitoring the situation and will provide updates as soon as they become available.