United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Mississippi Power Outage
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 03, 2025 - 15:39 UTC
Monitoring
There is a delay in MS due to a power outage causing the MEC (Mississippi Electronic Courts) website to go down. The following counties are affected Boliver, De Soto, Forrest, Jones, Jackson, Hinds, Lafayette, Lamar, Leake, Lee, Madison, Monroe, Marion, Newton, Neshoba, Prentiss, Rankin, Scott, MS Statewide, Sunflower, and Washington.
Please anticipate delays as orders will be run once the court website is operational. We are monitoring the situation.
Posted Jan 31, 2025 - 20:24 UTC