United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Fulton, GA

Incident Report for Checkr US Data Status

Update

Automation has been reenabled in Fulton GA and orders are processing as expected. Please anticipate delays as we work through the backlog.
Posted May 13, 2025 - 14:43 UTC

Monitoring

Please expect delays in turnaround time for Fulton, GA, as orders are currently being processed manually due to automation being down. We are actively monitoring the situation.
Posted May 07, 2025 - 19:24 UTC