[Outage] Montana DMV is Offline
Incident Report for Checkr Data Status
Resolved
The Montana DMV is back online and MVRs are once again processing as normal.
Posted Jan 18, 2023 - 19:54 UTC
Monitoring
The Montana DMV is still offline. No ETA has been provided by the state at this time. We will continue to monitor and update as more information becomes available.
Posted Jan 18, 2023 - 16:58 UTC
Identified
The Montana DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Jan 18, 2023 - 00:13 UTC