United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Cherokee, GA

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 22:02 UTC

Update

The Cherokee, GA site is currently down for maintenance. As a result, orders are being processed manually at this time. Please anticipate delays. We are monitoring the situation.
Posted Feb 11, 2025 - 22:56 UTC

Monitoring

The Cherokee, GA site is currently down for maintenance. Orders are not able to be processed until site is available again. Currently there is no ETA for restoration. We are monitoring the situation.
Posted Feb 07, 2025 - 20:20 UTC