United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Upcoming DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 05:01 UTC
Identified
The following DMVs will be performing scheduled maintenance during the windows listed below over the coming days (all times pacific):

Indiana: Thursday, February 8 from 3:30pm until 8pm
Mississippi: Friday, February 9 at 4pm until Sunday, February 11 at 4pm
Wisconsin: Saturday, February 10 at 12:01am until 4am
Tennessee, Saturday, February 10 at 2:30am until 8:30am
Delaware: Saturday, February 10 at 1am until Sunday, February at 1am

MVRs requested during these times will not be completed until the scheduled maintenance is completed.
Posted Feb 08, 2024 - 23:31 UTC