United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Maintenance] PACER

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 12:53 UTC

Monitoring

PACER has scheduled maintenance for Sunday, March 9th from 5am to 4pm ET. Service interruptions are expected during this time.
Posted Mar 05, 2025 - 17:58 UTC