United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Washington Statewide - Court Processing Delays

Incident Report for Checkr US Data Status

Update

Automated search processing has been restored. Some searches may continue to experience delays as the remaining backlog clears; monitoring remains active.
Posted May 13, 2026 - 00:25 UTC

Monitoring

Washington State courts have transitioned to a new court system, which is currently experiencing stability issues that are impacting automated search processing. Please expect intermittent delays as the court system works toward resolution. No ETA for resolution at this time.
Posted May 11, 2026 - 23:19 UTC