United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[DELAY] WINTER STORM COURT CLOSURES
Incident Report for Checkr US Data Status
Resolved
All impacted courts are now open.
Posted Jan 13, 2025 - 17:36 UTC
Monitoring
Due to the ongoing winter storm in the Mid Atlantic region the following courts are closed for 1/10/2025.

Kentucky: Allen, Boyle, Bullitt, Calloway, Crittenden, Graves, McCracken, Metcalfe, Muhlenberg, Perry, and Simpson

Tennessee: Hardeman, Henderson, Madison, McNairy, Loudon, DeKalb, Bradley, Meigs, Sequatchie, Rhea, Marshall, Lincoln, Moore, Smith, Trousdale, and Cocke.

Arkansas: Pulaski, Garland, Saline, Clark, Faulkner, Lonoke, Jefferson, White, Monroe, Pope, Independence, Prairie, Ouachita, Bradley, Hot Spring, St. Francis, Ashley, Desha, Drew, Dallas, Cleveland, Columbia, Calhoun, Crittenden, Cross, Craighead, Greene, Poinsett, Mississippi, Phillips, Lee, Woodruff, Jackson, Lawrence, Randolph, Clay, Fulton, Sharp, Izard, Stone, Baxter, Marion, Boone, Washington and Carroll.

Georgia: Fulton, Cobb, DeKalb, Gwinnett, and Clayton.

Delayed in Mississippi: Prentiss, Lee, and Monroe.

We are monitoring the situation.
Posted Jan 10, 2025 - 15:38 UTC