United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Puerto Rico Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 09, 2022 - 19:03 UTC
Monitoring
9/21/2022: Puerto Rico was hit by hurricane Fiona and is experiencing mass power outages and flooding, causing delays on searches with possible hits. Please expect major delays as they work to restore and rebuild. We will continue to monitor this and notify you of any changes.
Posted Sep 21, 2022 - 22:04 UTC