United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Riverside County, CA – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved – Automated search processing has been restored and normal operations have resumed.
Posted Mar 20, 2026 - 17:26 UTC

Update

Automated search processing has been restored and searches are processing normally. Some searches may experience delays while processing catches up. No ETA for resolution at this time.
Posted Mar 19, 2026 - 16:02 UTC

Monitoring

The court is experiencing system issues impacting some search processing. Some searches may experience delays. No ETA for resolution at this time.
Posted Mar 12, 2026 - 23:37 UTC