United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Mississippi DMV Scheduled Maintenance - Friday 11/10
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 16:54 UTC
Identified
The Mississippi DMV will be performing scheduled maintenance tomorrow, 11/10, from 6am until 3pm PT. MVRs in Mississippi requested during this time will not be completed until the scheduled maintenance is completed.
Posted Nov 09, 2023 - 20:53 UTC