United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Louisiana and southern Mississippi counties - Tropical Storm Francine
Incident Report for Checkr US Data Status
Resolved
The Louisiana and Mississippi counties that were affected by the Tropical Storm are back to normal operations. Please expect delays as the researchers catch up on searches.
Posted Sep 13, 2024 - 21:25 UTC
Update
Please note the following court closures due to Tropical Storm Francine. We will continue to monitor the situation and notify you of any changes.

Louisiana Court Closures on Wednesday: Ascension, Saint Mary, Iberia, Saint Martin, Evangeline, Acadia, Lafayette, Saint Landry, Avoyelles, West Feliciana, East Feliciana, Washington, Saint Tammany, La Salle, Catahoula, Concordia, and Vernon.

Louisiana Court Closures on Wednesday and Thursday: Livingston, Orleans, Plaquemines, St. John, St. James, Lafourche, Jefferson, Vermilion, East Baton Rouge, West Baton Rouge, Iberville, Pointe Coupee, Terrebonne, Saint Charles, Saint Bernard, and Tangipahoa.

Mississippi Court Closures on Wednesday: Adams, Pearl River, Greene, George, Hancock, Lincoln, Pike, Harrison, Stone, and Jackson.
Posted Sep 11, 2024 - 19:24 UTC
Monitoring
Please expect delays in Louisiana and southern Mississippi counties over the next few days due to Tropical Storm Francine. We’re actively monitoring the situation and will keep you informed of any updates.
Posted Sep 11, 2024 - 15:27 UTC