[Planned Outage] Florida DMV Maintenance 4/15 - 4/18
Incident Report for Checkr Data Status
Resolved
Maintenance has been completed and Florida MVRs are now processing.
Posted Apr 19, 2022 - 15:07 UTC
Identified
The Florida DMV will be offline beginning at 4pm Pacific on Friday, April 15 until 6am Pacific on Monday, April 18 for scheduled maintenance. MVRs will be unavailable during this time and any requests placed during the maintenance window will be completed once service is restored.
Posted Apr 13, 2022 - 19:51 UTC