United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Marshall, TN
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 00:15 UTC
Update
The Marshall County clerks confirmed this morning that there is a temporary fix in place to conduct searches. We are still experiencing delays but are monitoring progress.
Posted Jan 23, 2025 - 18:18 UTC
Monitoring
The court system is down and we are unable to process searches at this time. We are monitoring the situation and ETA for restoration is 1/24/2025.
Posted Jan 22, 2025 - 16:30 UTC