Data Status Page

This page contains information about third-party data source disruptions and delays.

Hancock County, Mississippi – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved - normal search operations have resumed.
Posted Aug 20, 2026 - 00:00 UTC

Update

The court clerk has returned to office and is processing search requests within a daily submission limit the court put in place in October. Requests are being submitted at the maximum volume allowed each day, and results are posted as received. No ETA for resolution at this time.
Posted Aug 05, 2026 - 00:53 UTC

Update

Hancock County, MS — Court staffing limitations are currently impacting search processing.
Posted Jul 21, 2026 - 21:55 UTC

Update

Court staffing limitations are currently impacting search processing. ETA updated to July 1, 2026.
Posted Jun 30, 2026 - 06:28 UTC

Monitoring

Hancock County, MS — Court staffing limitations are currently impacting search processing. Searches are expected to resume Monday, June 29, 2026.
Posted Jun 22, 2026 - 20:20 UTC