United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Hawaii DMV

Incident Report for Checkr US Data Status

Resolved

Hawaii MVRs are once again processing. Please continue to expect delays as we work through the backlog.
Posted Mar 17, 2023 - 15:18 UTC

Identified

The Hawaii DMV is experiencing a server issue that is causing a delay in fulfilling MVRs. Our team reached out to the state for more information and was told that their technicians are working on a resolution. They are unable to provide an ETA for resolution at this time.

We will let you know as soon as we receive additional information.
Posted Mar 16, 2023 - 18:55 UTC