Orders are now processing in Washington. Please continue to expect delays as our researchers work through the backlog
Posted Nov 19, 2024 - 21:21 UTC
Update
The Washington Administrative Office of the Courts (AOC) is in the process of bringing systems on the Washington Courts network online. The WA AOC website and JIS-Link are back online; however, they have cautioned that intermittent disruptions may occur as the system is fully restored. Please continue to expect delays.
Posted Nov 19, 2024 - 16:38 UTC
Update
The Washington Administrative Office of the Courts (AOC) anticipates that service interruptions will continue throughout the week as they work to secure and restore the court network. Currently, there is no estimated time for full restoration, so please continue to expect delays. We are unable to process orders at this time.
Posted Nov 13, 2024 - 19:20 UTC
Monitoring
Washington's primary online index, JIS-Link, is down with no current ETA for restoration. We are unable to process order at this time. Please expect delays.