United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Indiana and Florida DMV Scheduled Maintenance

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Sep 25, 2023 - 15:55 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 22, 2023 - 21:00 UTC

Identified

The Indiana DMV will be performing scheduled maintenance today from 3:30-8pm PT.
The Florida DMV will be performing scheduled maintenance today from 4-9pm PT.

MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Sep 21, 2023 - 18:12 UTC