Data Status Page

This page contains information about third-party data source disruptions and delays.

Drug and Occupational Health Testing – Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved: The technical issue affecting drug and occupational health screening orders has been resolved. Screening passes are now available for all impacted orders, and candidates can proceed with testing.
Posted Aug 13, 2026 - 19:18 UTC

Monitoring

A technical issue affecting one of our data providers is delaying screening pass generation for drug and occupational health testing orders. Candidates may experience a delay before they're able to complete testing. No ETA for resolution at this time.
Posted Aug 13, 2026 - 18:19 UTC